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1 Functional Description

1.1 Description Overview

User's Guide
SLEU081A–March 2007–Revised July 2007

TVP9900EVM User’s Guide

The TVP9900EVM evaluation module is a printed circuit board (PCB) designed for evaluation of the
TVP9900 VSB/QAM receiver. The board is designed with a 36-pin connector that allows connection to
multiple radio-frequency (RF) tuner boards; the EVM is shipped with a standard tuner module. The board
is designed to provide ease of use, while allowing full evaluation of the TVP9900 VSB/QAM receiver.

The TVP9900EVM provides the user one RF input through a standard RF connector. The EVM provides,
as an output, a digital parallel or serial MPEG-2 transport stream that is compliant to DVB-SPI. This output
stream can be easily connected to a BER tester or to an MPEG-2 decoder, such as the TVP9000.

The differential intermediate frequency (IF) output signals from the tuner board are input to the TVP9900,
which supports processing of ATSC 8-VSB or ITU-T Annex B QAM IF inputs with forward error correction
(FEC). It provides peripheral support including automatic gain control (AGC) control, direct tuner control,
and antenna control. In general, the receiver demodulates the input IF signal into a digital MPEG-2
transport stream, with advanced integrated features for AGC control, filtering, tracking, and error
correction. An AGC control interface can be used to control the IF AGC amplifier gain in the tuner. The
outputs supported by the EVM include parallel/serial MPEG-2 outputs with error packet indicator.

A 25-MHz clock is required to drive the PLL of the TVP9900. Some tuner devices have a 4-MHz clock
output that can be used as the demodulator clock source. The TVP9900EVM has the option of using a
4-MHz clock input from the tuner as the clock source, or the default setting of using the onboard 25-MHz
crystal. This selection is controlled by Jumper 1 together with R24, R25, and R26. See Section 2.1 for
more details.

The TVP9900 includes the option of attaching a 12-V power supply and using the modular jack interface
to provide CEA-909 compliant smart antenna control. The TVP9900 receives the antenna parameters
from the host processor via I2C and sends the modulated PWM signal to the antenna. The antenna
parameters include antenna direction, antenna polarization, preamplifier gain, and channel number.

The TVP9900EVM uses the PC parallel port to emulate the I2C bus, which provides communication with
the TVP9900 receiver and the RF tuner. WinVCC (Windows® Video Control Center), a Windows
compatible application, communicates with the devices via the I2C and is provided on the EVM CD-ROM.
This application software provides the user interface to experiment with the programmable features and to
perform register-level and high-level control of the TVP9900 receiver and the RF tuner. The TVP9900EVM
provides the option of whether the TVP9900 or the PC is the tuner I2C master. This is controlled with
jumpers 4 and 5, and the configuration is automatically detected by the WinVCC software. See
Section 2.1 for more details.

All trademarks are the property of their respective owners.
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2 Board-Level Description
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2.1 Test Points and Jumpers

Board-Level Description

The TVP9900EVM consists of the TVP9900EVM module and the tuner EVM module. A two-row 36-pin
connector connects the boards. The block diagram of the EVM set is shown in Figure 1.

Figure 1. TVP9900EVM Block Diagram

The TVP9900EVM was designed with test points and jumpers to help in evaluation and troubleshooting.
Each jumper is set by default to its preferred state for the TVP9900EVM. There are test points for I2C SCL
and SDA, GND, 5 V, 3.3 V, and 1.5 V. The digital MPEG-2 transport stream data and GPIO signals are
brought out to two dual-row headers that allow easy connect to test equipment.

The I2C address selection is made with one shunt jumper, which is only read after a reset or at power up.
The default address is 0xB8.

Note: If the I2C address is changed on either the TVP9900 board or the tuner board while the
TVP9900EVM is powered up, that device does not recognize the new I2C address. The
reset button on the TVP9900EVM must be pressed, and WinVCC must be exited,
restarted, and configured for the new I2C address.

Table 1. I2C Address Selection Jumper (I2CA0, JP2)

JP2 I2C Address

ON 0xB8

OFF 0xBA

Table 2. Power-Down Mode Selection Jumper
(PWRDOWN, JP3)

JP3 Mode

ON Normal operation

OFF Power-down mode
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2.2 Common Board Interface

2.3 Input Description

Board-Level Description

JP1, together with R24, R25, and R26, control whether a 4-MHz clock from the tuner or a 25-MHz clock
from the onboard crystal are used to drive the TVP9900. The jumper settings and resistor populate (POP)
or do-not-populate (DNP) options are listed in Table 3. The default setting is for the 25-MHz clock.

Table 3. Clock Input Selection Jumper (CLKIN_SEL, JP1)

JP1 R24 R25 R26 Clock

ON POP POP DNP 25 MHz

OFF DNP DNP POP 4 MHz

The TVP9900EVM provides the option of whether the TVP9900 or the PC is the tuner I2C master, and this
is selected with JP4 (SCL) and JP5 (SDA). The default setting is for the TVP9900 to be the I2C master.

Table 4. Tuner I2C Master Selection Jumper
(TUNSCL, JP4 and TUNSDA, JP5)

JP4 JP5 I2C Master

1-2 1-2 PC

2-3 2-3 TVP9900

The TVP9900 has a CEA-909 compliant smart antenna control interface and the TVP9900EVM has the
option of supporting either a Mode A (basic one-direction control) or Mode B (advanced bidirectional
control) antenna using the 1-pin mode of the smart antenna control interface pin on the TVP9900 (pin 29).
JP6 is used to enable or disable Mode B for smart antenna support. The default setting is for Mode A.

Table 5. Mode B Selection Jumper (Mode B, JP6)

JP6 Mode

1-2 Mode A

2-3 Mode B

The TVP9900EVM uses a two-row 36-pin connector (H1) to share common signals and the 5-V power
supply between the boards. This connection allows multiple tuner boards to be connected to the
TVP9900EVM. The EVM package is shipped with a standard tuner module. This connector shares the
differential IF signals, AGC, 5 V, ground, I2C bus (SCL and SDA), and, if desired, a 4-MHz clock, two
general-purpose input/output (GPIO) signals, and reset.

The differential IF output signals from the tuner board are input to the TVP9900, which supports
processing of ATSC 8-VSB or ITU-T Annex B QAM IF inputs with forward error correction (FEC).

The TVP9900EVM receiver has an analog input channel that accepts one differential or single-ended
44-MHz center frequency IF input that is ac coupled. The receiver supports a maximum differential input
voltage range of 1 V peak-to-peak. The programmable gain amplifier (PGA) and the AGC circuit work
together and make sure that the input signal is amplified sufficiently to ensure the proper input range for
the ADC. An external downconverter is not required to use the IF direct sampling method. The analog
front end and adjacent digital filter relax the requirement for external analog filters, and only one external
SAW filter is required.
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2.4 Output Description

3 System-Level Description
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4 Required Hardware and Equipment

System-Level Description

The EVM provides, as an output, a digital parallel or serial MPEG-2 transport stream that is compliant to
DVB-SPI. The 8-bit MPEG-2 transport stream data output of the TVP9900, together with the clock and
packet signals (see following list), are routed to a 20-pin header (H3) and then to an LVDS line driver,
which is connected to a standard DB25F edge connector. This output stream can be easily connected to a
bit error rate (BER) tester or to a MPEG-2 decoder. In serial mode, the DATAOUT7_SO pin is used as the
serial data output (available on pin 17 of header 3), with the most-significant bit (MSB) output first. The
maximum output rate is 42.1 Mbit/s in serial mode.

MPEG-2 clock and packet signals:

• DCLK – Data clock output
• PACK_SYNC – Byte start signal (indicates the first byte of a transport stream data packet)
• BYTE_VALID – Interface packet framing signal (indicates length of the valid data packet)
• D_ERROR – Interface data error (indicates an error in the data output packet)

A system-level block diagram incorporating the TVP9900 is shown in Figure 2. The primary features of
this configuration are:

• Power is provided by a single 5-V power supply provided with the EVM and is shared between both
modules via the 36-pin connector.

• Supports one RF input through a standard RF connector
• Provides 8-bit MPEG-2 parallel or serial transport stream data output
• I2C bus initializes the video devices via a PC parallel port.
• TVP9900 VSB/QAM receiver performance parameters may be measured with a BER tester.

Figure 2. TVP9900EVM System-Level Block Diagram

The required hardware and equipment necessary to use the TVP9900EVM are:

• TVP9900EVM (provided)
• Universal 5-V power supply (provided)
• Parallel cable (provided)
• Windows-based PC with CD-ROM drive and Win95™ or later
• RF cable for input
• Parallel cable for output
• RF video source (terrestrial antenna, DTV cable, 8VSB/QAM test transmitter, etc.)
• MPEG-2 decoder or BER tester
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5 Hardware Setup

6 Software Installation

Hardware Setup

Figure 1 shows the TVP9900EVM layout and indicates the location of the power supply and the
appropriate connectors. All connectors are labeled according to their function. To prepare the EVM for
evaluation, connect the following:

1. There are two parallel interfaces on the EVM. The one labeled J3 is for the I2C interface to the PC.
Connect a parallel port cable from this connector on the EVM to the PC.

2. The other connector, labeled J2, provides a digital MPEG-2 transport stream that is compliant to
DVB-SPI. Connect this to a BER tester or to an MPEG-2 decoder.

3. Connect an RF video source to the TVP9900EVM tuner board RF input.
4. Connect the 5-V power supply to the dc jack on the TVP9900 board. A green LED on the board should

now be lit.

The I2C slave address can be selected with jumper JP2. There are two possible addresses: 0xB8 and
0xBA. The default setting for this jumper is for the shunt to be in place, which selects 0xB8. This is
connected to TVP9900 pin 38, which is read at power up. If the shunt is removed and the EVM reset, the
TVP9900 now responds to I2C slave address 0xBA. The tuner I2C address is set by default on the tuner
EVM board to 0xC2 (tuner board jumper JP1 is open). This jumper setting is required to match the I2C
slave address in the Tuner Type window in the WinVCC software.

Note: If the I2C address is changed on the TVP9900 or tuner board while the TVP9900EVM is
powered up, the device does not recognize the new I2C address. The reset button on the
TVP9900EVM must be pressed, and WinVCC must be exited, restarted, and configured
for the new I2C address.

WinVCC is a Windows application that uses the PC parallel port to emulate I2C, providing access to each
device on the I2C bus. WinVCC makes use of CMD files, which are text editable files that allows preset
receiver setups to be programmed easily.

This feature allows the user to easily set multiple I2C registers with the press of a button. WinVCC also
has property sheets for the TVP9900, which allow the user to control the I2C registers with a GUI. A tuner
control page is provided to setup and control the included RF tuner.

All necessary software for the TVP9900EVM is provided on the enclosed CD. Perform the following steps
to install WinVCC:

1. Explore the provided TVP9900EVM software CD.
2. Install Port95NT.exe. This is the parallel port driver used by WinVCC. This driver must be installed and

the PC must be rebooted before WinVCC can operate correctly. This does not affect normal parallel
port operation.

3. Install Setup.exe. Click Next at all prompts and click Finish to complete the installation process. This
installs WinVCC onto the PC. No reboot is required.

4. Run WinVCC.exe.

Note: A shortcut to WinVCC and additional TVP9900 related documentation can be found at
Start→All Programs→TVP9900EVM Software.
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7 WinVCC Quick Start

WinVCC Quick Start

Perform the following steps to get an MPEG-2 transport stream out of the TVP9900EVM.

1. Once WinVCC is executed, the WinVCC Configuration screen appears, as shown in Figure 3. This
dialog box configures the I2C bus. Next to TVP9900, select the TVP9900 and ensure the I2C address
is set to 0xB8 (default setting on EVM.) This must match the I2C ADDR jumper on the TVP9900 board.

2. The tuner I2C address is set by default in WinVCC to 0xC2. This is also the default setting on the tuner
EVM board; verify the correct TUNER_AS jumper setting on the tuner board.

Note: If WinVCC is running and the TVP9900 or tuner board I2C address is changed, power
must be cycled on the EVM.

Figure 3. WinVCC – I2C Configuration Screen

3. Ensure that all other boxes are set to NOT USED and that all program options buttons are set to
ENABLE. Click OK.

4. If there are no I2C communication issues, the WinVCC Main Screen dialog window displays next, as
shown in Figure 4. If there are I2C issues, an I2C Test Report box displays. Completely exit out of
WinVCC, double check the parallel port cable connections, cycle power on the TVP9900EVM, and run
WinVCC again.

Figure 4. WinVCC – Main Screen

SLEU081A–March 2007–Revised July 2007 TVP9900EVM User’s Guide 11
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WinVCC Quick Start

5. Load the provided initialization command (CMD) file into WinVCC by clicking on Tools→System
Initialization and clicking Browse. The default directory is C:\Program Files\Texas
Instruments\WinVCC\TVP9900\Initialization.

6. In the System Initialization Window, shown in Figure 5, click the "Program TVP9900 - 8-VSB mode -
outputs enabled" dataset in the window and then click PROGRAM Device(s) Using Selected Dataset to
initialize the TVP9900EVM for 8-VSB mode. The 64QAM mode and 256QAM mode can be set up by
using the other datasets in this command file.

Figure 5. WinVCC – System Initialization

7. Click Close.
8. Program the tuner by clicking Tools→TV Tuner Control→ ATSC. The Tuner Type window, as shown in

Figure 6, allows the user to select tuner and source settings. Select the Standard Digital ATSC Tuner
button and click on OK to use the default tuner shipped with the TVP9900EVM.

Figure 6. ATSC Tuner Type

9. In the TV Tuner Control window, as shown in Figure 7, select a channel from the "Add to Channel List"
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WinVCC Quick Start

drop down box.
10. Click Add. After approximately one second, the tuner is programmed to the selected channel.
11. For direct entry of the RF center frequency, type in the center frequency (for example, 189) into the

"RF Center Freq (MHz)" box. Click Program to program the tuner.

Figure 7. TV Tuner Control for ATSC

12. To perform a channel scan when the input is from an antenna (or cable), click Start on the TV Tuner
Control page. This selects all channels for which the TVP9900 indicates locked status. The locking
criteria are selectable on this page: Field Sync Lock (Default: ON), Timing Recovery (Default: ON), and
FEC Sync Lock (Default: ON). The Pre-Delay is not needed.

13. After scanning, switching between channels can be easily done using the channel up/down buttons
(Ch Up and Ch Down) or the "Channel Changer" drop-down list.

14. Click OK to close the TV Tuner Control tool.
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WinVCC Quick Start

15. Open the TVP9900 Property Sheets by clicking Edit→Property Sheets→TVP9900. Click on the Status
tab, as shown in Figure 8. Click Auto-Update to enable it, and then click Soft Reset. The demodulator
and FEC status are shown on this page.

Figure 8. TVP9900 Property Sheets

16. With an RF source provided to the tuner RF connector, and the EVM output connected to a BER
tester or MPEG-2 decoder, the MPEG-2 transport stream should be available. If the transport stream is
not output from the TVP9900EVM, ensure the following is correct:

• The input/output cables are connected correctly to the sources, EVM, and tester/decoder.
• The input source is working properly and providing the expected RF input. Lock can be confirmed

with the above property sheet.
• The correct dataset is selected and programmed for the correct RF input format.
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8 WinVCC in Depth

8.1 Starting WinVCC

8.2 WinVCC Configuration Dialog Box

WinVCC in Depth

The following sections describe how to use WinVCC in depth. It discusses various features and screens
that the user may encounter while evaluating the TVP9900EVM.

The Port95NT parallel port driver must be installed before using WinVCC. WinVCC may be started by
clicking on Start→All Programs→TVP9900EVM Software→WinVCC.

If the dialog box shown in Figure 9 is displayed, then it means one of two things:

• WinVCC terminated abnormally the last time it ran. In this case, click OK to exit the program and
restart WinVCC.

• There is more than one instance of WinVCC running at the same time. In this case, click OK to exit the
program. Then, press Ctrl+Alt+Delete to open the Task Manager. Select and click End Task on all
occurrences of WinVCC or WinVCC CONFIGURATION. Restart WinVCC.

Figure 9. WinVCC Multiple Occurrences Error Message

The WinVCC Configuration dialog box, as seen in Figure 10, should now be visible. This dialog box
configures the I2C bus on the TVP9900EVM. All settings from this dialog box are stored in the Windows
registry and are restored the next time the program is started. After initial installation, the TVP9900
(QAM/VSB Receiver) device family is set to TVP9900, and all other devices are set to NOT USED.

The I2C slave address for each device must match the I2C slave address selected by jumpers on the
TVP9900EVM. These jumpers are set by the factory to use 0xB8 for the TVP9900 and 0xC2 for the tuner.

All Program Options must be enabled. Disabling these options is only required if you are debugging a
problem with the I2C bus.

Click OK to begin I2C communication with the selected devices.
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8.3 I2C System Test

WinVCC in Depth

Figure 10. WinVCC I2C Address Configuration

The I2C system test of the selected devices runs immediately after closing the WinVCC Configuration
dialog box by clicking OK (unless the I2C system test program options button was disabled).

If the test fails, a dialog box similar to Figure 11 appears. See Section 10, Troubleshooting, for details on
how to resolve this issue.

The I2C system test can be run at anytime by clicking Run System I2C Test in the Tools menu.
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8.4 Main Menu

WinVCC in Depth

Figure 11. I2C System Failure

After closing the WinVCC configuration dialog, the main menu is displayed (see Figure 12). The menus
that are used to operate WinVCC are File, Edit, Tools, Window, and Help. The File menu’s only function is
Exit, which terminates the program. Table 6 summarizes the main menu contents.

Figure 12. WinVCC – Main Screen
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8.4.1 System Initialization

WinVCC in Depth

Table 6. Main Menu Summary

Menu Contents

File Exit

Register Map
TVP9900

Edit Generic I2C
Property Sheets

TVP9900

System Initialization
Real-time Polling
TV Tuner Control

NTSC CATV
PAL CATVTools ATSC

Multi-byte I2C Transfers
Set I2C Bit Rate
Run System I2C Test
Run Continuous I2C Test

Window Allows selection of the active window. Multiple windows can be open at the same time.

Help Displays program version

Clicking System Initialization in the Tools menu displays the dialog box shown in Figure 13. This dialog
box provides the means for initializing the TVP9900 receiver for a particular IF input mode. The details of
the initialization are contained in the command file (with a CMD file extension).

The command file is loaded by clicking Browse. Once the command file is opened, a text list displays
descriptions of the individual datasets contained within the command file.

Click once on the desired dataset description to select it. Click Program Device(s) Using Selected Dataset
to run the selected dataset, which loads the devices via the I2C bus. When the device initialization has
completed, the status indicator displays Ready.

Note: If Ready does not display, the devices are not initialized, and the I2C bus is not
communicating. See Section 10, Troubleshooting, for possible solutions.

Click Close to close the dialog box. Each time the System Initialization dialog box is closed, the
initialization file pathname and the dataset selection number are saved in the Windows registry to allow
these settings to be retained for the next time WinVCC runs.
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8.4.1.1 Adding a Custom Dataset

8.4.1.2 Command Files

WinVCC in Depth

Figure 13. System Initialization

After programming the EVM via the System Initialization tool using the factory-supplied command file,
customize the device register settings to fit the application needs. Perform the following steps to save the
custom settings:

1. Reopen the System Initialization dialog box via the Tools menu.
2. Click Append Current Device Settings to Command File. A dialog box requesting a description of the

new dataset appears.
3. Optionally, click the drop-down box and select one of the existing descriptions.
4. Modify the description text or type your own description.
5. Click OK. All non-default register values from the TVP9900 and tuner are appended to the current

command file as an additional dataset.

Select the custom dataset and load it by clicking Program Device(s) Using Selected Dataset.

Using the same procedure but clicking Replace Selected Dataset with Current Device Settings overwrites
an existing dataset with the current settings.

Note: If editing the command file (.CMD) using a standard editor, the file must be saved as plain
text.

The command file is a text file that can be generated using any common editor; however, it must be saved
as plain text. In Windows Explorer, use right-click→Edit to open a command file. (Double clicking on a
command file or using right-click→Open causes the command file to run as a script in a DOS window.)

Command files are especially useful for quickly switching between various system configurations. A
default command file has been provided on the CD. This command file contains examples of common
setups. This command file is located at:

C:\Program Files\Texas Instruments\WinVCC\TVP9900\Initialization\
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8.4.1.3 Example Command File

WinVCC in Depth

A command file can contain up to 250 datasets. A dataset is a set of register settings to initialize the
TVP9900 receiver and/or tuner for a particular IF input mode. Each dataset includes a description that is
displayed in one row of the dataset descriptions list. The register settings may be located in the command
file itself and/or may be stored in separate include file(s) (with an .INC file extension) and be included into
the command file using the INCLUDE statement.

An example of one dataset within a command file is shown below.
BEGIN_DATASET

DATASET_NAME,"Program TVP9900 - 8-VSB mode - outputs enabled"

WR_REG,TVP9900,1,0X53, 0XFF // Enable outputs and clock
WR_REG,TVP9900,1,0X54, 0X03
WR_REG,TVP9900,1,0X00, 0X20 // soft reset

END_DATASET

Each command file may contain individual write-to-register (WR_REG) commands.

• The comment indicator is the double-slash, //.
• The command file is not case sensitive and ignores all white-space characters.
• All numbers can be entered as hexadecimal (beginning with 0x) or as decimal.
• Every dataset in a command file begins with BEGIN_DATASET and ends with END_DATASET. The

maximum number of datasets is 250.
• The dataset text description is entered between double quotes using the DATASET_NAME command.

The enclosed text can be up to 128 characters in length. This text appears in the System Initialization
dialog box when the command file is opened.

• The INCLUDE command inserts the contents of an include file (with an .INC file extension) in-line in
place of the INCLUDE command. Therefore, the include file must not contain the BEGIN_DATASET,
END_DATASET, and DATASET_NAME commands.

Note: All included files must be located in the same directory as the command (CMD) file.

• The write-to-register command is written as follows:
WR_REG, <DeviceFamily>, <Number of data bytes (N)>, <subaddress>, <Data1>,…, <DataN>

or
WR_REG, <Literal slave address>, <Number of data bytes (N)>, <subaddress>, <Data1>,…, <DataN>
The valid device family mnemonics are:

VID_DEC for the video decoders
VID_ENC for the video encoders
TVP9000 for the TVP900x HDTV video processors
TVP9900 for the TVP9900 VSB/QAM demodulator
TVP7000 for the TVP700x video/graphic ADC devices
THS8200 for the THS8200 HDTV/SDTV/RGB DAC device

WinVCC translates the device family mnemonic to the slave address that was selected in the WinVCC
Configuration dialog box upon program startup. This eliminates the need to edit command files if the
alternate slave address must be used.
If the literal slave address method is used, then the slave address entered is used directly. This
method can be used for programming the tuner.

• A delay may be inserted between commands using the WAIT command, which is written as follows:
WAIT,<# milliseconds>

• If an I2C write without a subaddress is required, use two consecutive commas instead of
"subaddress,".
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8.4.2 Register Editing

8.4.2.1 Register Map Editor

WinVCC in Depth

The following sections describe the three available modes of register editing: register map editor, generic
I2C register editor, and TVP9900 property sheets. Each of these functions can be selected from the Edit
menu.

The register map editor (see Figure 14) allows the display and editing of the entire used register space of
the device within a simple scrolling text box. To open this, click on Register Map in the Edit menu and
click on the device type to edit. Table 7 describes how to use each of the controls in the register map
editor.

Figure 14. Register Map Editor

Table 7. Register Map Editor Controls

Control Definition

Register Window Scrolling text box that displays the address and data for the I2C registers that are defined for the device

This contains the I2C subaddress that is accessed using the Write and Read buttons. Clicking on a row
selects an address, which then appears in the address edit box.
NOTE: After clicking on a row, the Data Edit box contains the data that was in the register window. The

Address Edit Box device has not yet been read.
The address up/down arrows are used to jump to the next/previous subaddress that is defined for the
device. If an address is not defined for the device, it can still be accessed by typing the subaddress in
the Address Edit box.

This contains the data which will be written to or was read from the I2C subaddress. The data up/downData Edit Box arrows increment/decrement the data value by 1.

Writes the byte in the Data edit box to the address in the Address edit box. The I2C register is written toWrite Button whether or not the data is different from the last time the register was read.

Read Button Reads the data from the address in the Address edit box into the Data edit box and the register window

Read All Button Reads all defined readable registers from the device and updates the register window

Hex Button Converts all values in the register window and address and data edit boxes to hexadecimal

Dec Button Converts all values in the register window and address and data edit boxes to decimal

Closes the dialog
Close Button NOTE: Multiple edit register map windows can be open at the same time (one for each device). Use the

Window menu to navigate.

Causes subsequent write, read, or read all operations to be performed N times. N is entered as aLoop Count decimal number from 1 to 999.
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8.4.2.2 Generic I2C Register Editor

8.4.2.3 TVP9900 Property Sheets

WinVCC in Depth

The generic I2C register editor (see Figure 15) allows the display and editing of any device on the I2C bus.
This editor works like the TVP9900 register map editor, except that the I2C slave address must be entered
and the Read All button is disabled.

To open this window, click Register Map in the Edit menu and then click Generic I2C.

Figure 15. Generic I2C Register Editor

The property sheets represent the register data in a user-friendly format. The data is organized by
function, with each function having its own page and being selectable via tabs at the top (see Figure 16).

To open this, click on Property Sheets in the Edit menu and select the device type to edit.

When the property sheet function is started or when tabbing to a different page, all readable registers in
the device are read from hardware to initialize the dialog pages. Values on the page are changed by
manipulating the various dialog controls as described in the Table 8.

There are OK, Cancel, and Apply buttons at the bottom of each property page. These are explained in
Table 9.
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WinVCC in Depth

Figure 16. Property Sheets

Available on the TVP9900 Property Sheets Status page is a Constellation / Eye Diagram plot tool and a
four-channel virtual oscilloscope tool. Both analysis tools are accessed by clicking on the respective button
on the Status page.

The Eye Diagram / Constellation window (see Figure 17) displays signal variation at the carrier recovery
slicer input with persistent plots and allows the user to save data to a log file. The eye diagram displays
I-data at three consecutive points, and the constellation plot shows the distinct I-data levels along the
horizontal axis.

Figure 17. Eye Diagram / Constellation Plots
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WinVCC in Depth

The four-channel oscilloscope tool (see Figure 18) stores all acquired data from time zero and provides
the option of saving data for off-line analysis. This tool provides many useful features to aid in signal
analysis, including the following:

• Real-time plots of up to four status registers
• Real, magnitude, phase, or Doppler plot types
• Variable time and division
• Variable Y offset and Y scale, with automatic Y scale
• Horizontal pan and zoom

Figure 18. Four Channel Scope

8.4.2.3.1 Property Sheet Refresh

The property sheets were designed so that the data displayed is always current. Certain actions cause the
entire register map to be read from the device and to update the property sheets:

• When property sheets are initially opened
• When tabbing from one page to another
• When Read All is clicked
• When making the property sheets window the active window (by clicking on it)
• When making a register map editor window the active window (by clicking on it)

8.4.2.3.2 Auto-Update From Device

Items 4 and 5 above are referred to as the auto-update feature. Auto-update can be disabled by setting its
program option button to DISABLED. This button is located on the initial dialog box (WinVCC
Configuration).
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WinVCC in Depth

The user can open both the property sheets and the register map editor at the same time, and changes
made to the property sheets (and applied) are updated in the register map window as soon as the register
map window is clicked on. Additionally, changes made in the register map editor are updated in the
property sheets as soon as the property sheets window is clicked on.

Table 8. Use of Property Sheet Controls

Dialog Control What Do I Do With It? When Is Hardware Updated?

Read-only edit box Read status information N/A

Check box Toggle a single bit After Apply

Drop-down list Select from a text list After Apply

Edit box Type a number After Apply

Up/Down Arrows: ImmediatelyEdit box with up/down arrows Use up/down arrows or type a number Type a number: After Apply

Slider Slide a lever Immediately

Push button Initiate an action Immediately

Table 9. Property Sheet Button Controls

Button Control Definition

Writes to all writeable registers whose data has changed. A register is flagged as changed if the value toOK be written is different from the value last read from that address. Closes the dialog.

Causes all changes made to the property page since the last Apply to be discarded. Changes made to
dialog controls with ‘immediate hardware update’ are not discarded, since they have already been

Cancel changed in hardware.
Does not write to hardware.
Closes the dialog.

Writes to all writeable registers whose data has changed. A register is flagged as changed if the value toApply be written is different from the value last read from that address.
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9 TV Tuner Control

TV Tuner Control

This chapter discusses how to program the tuner on this EVM. Program the tuner by clicking Tools→TV
Tuner Control→ ATSC. The Tuner Type window (see Figure 19) allows the user to change the tuner I2C
slave address (C2h by default) and RF source settings. Click the Standard Digital ATSC Tuner button and
click OK to use the default tuner shipped with the TVP9900EVM.

Figure 19. ATSC Tuner Type

To use other tuner boards that have the same TVP9900 EVM board interface, click the Custom Digital
ATSC Tuner button. This allows the user to select a tuner configuration file that is used to program the TV
Tuner Control settings to work with the desired tuner. Additional details and an example Tuner
Configuration File can be provided by Texas Instruments if this option is desired.

In the TV Tuner Control window (see Figure 20), select a channel from the "Add to Channel List"
drop-down box. Click Add. After approximately 1 second, the tuner is programmed to the selected
channel. For direct entry of the RF center frequency, type in the center frequency (for example, 189) into
the "RF Center Freq (MHz)" box. Click the Program button to program the tuner.

26 TVP9900EVM User’s Guide SLEU081A–March 2007–Revised July 2007
Submit Documentation Feedback

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLEU081A


www.ti.com

TV Tuner Control

Figure 20. TV Tuner Control for ATSC

To perform a channel scan when the input is from an antenna (or cable), click Start on the TV Tuner
Control page. This selects all channels for which the TVP9900 indicates locked status. The locking criteria
are selectable on this page: Field Sync Lock (Default: ON), Timing Recovery (Default: ON), and FEC Sync
Lock (Default: ON). The Pre-Delay is not needed. After scanning, switching between channels can be
easily done using the channel up/down buttons (Ch Up and Ch Down) or the "Channel Changer"
drop-down list.

Open the TVP9900 Property Sheets by clicking Edit→Property Sheets→TVP9900. Click the Status tab, as
shown in Figure 16. Click Auto-Update to enable it, and then click Soft Reset.
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10 Troubleshooting

10.1 Troubleshooting Guide

Troubleshooting

This chapter discusses ways to troubleshoot the TVP9900EVM.

If you are experiencing problems with the TVP9900EVM hardware or the WinVCC software, see Table 10
for available solutions.

Table 10. TVP9900EVM Troubleshooting

Symptom Cause Solution

At startup, the error message Cannot The parallel port driver supplied withfind DLL file DLPORTIO.DLL Run Port95NT.EXE on the CD to install the driver.the EVM has not been installed.appears.

Program the tuner by clicking Tools→TV Tuner
Control→ATSC. The tuner type and settings are

Tuner is not programmed correctly. programmed for the default tuner shipped with the
EVM. Different tuners must be programmed

Blank screen separately.

Go to Edit→Property Sheets→TVP9900, MPEGMPEG-2 data outputs, clock, or Output Control page, click the DATAOUT Enablepacket signals are disabled. and Signal Enable buttons and click Apply.

WinVCC I2C test fails unexpectedly Initial test fails to operate correctly. Exit out of WinVCC, and restart.

Make sure I2C slave address jumper on the
Receiver I2C slave address is wrong. TVP9900 receiver module is set for the correct

address.

Make sure I2C slave address jumper on the tunerTuner I2C slave address is wrong. module is set for the correct address.

Parallel cable is not connected from
PC parallel port to the TVP9900 Connect cable
receiver module DB25 connector.

Power supply must be plugged into a 100-V to
240-V/47-Hz to 63-Hz power source, and the cordEVM is not powered on. must be plugged into the power connector on the
EVM.

Some parallel cables are not wired straight throughWrong type of parallel cableNo I2C communication pin-for-pin. Use the cable supplied with the EVM.

Verify jumper JP3 is set to its default (shunt is on)Device was placed in power-down position. Press the Reset button on the TVP9900mode. Receiver Module.

DO THIS AS A LAST RESORT. Reboot PC, enter
BIOS setup program, and set parallel port LPT1

PC parallel port mode is not set mode (Addr 378h) to ECP mode or bidirectional
correctly. mode (sometimes called PS/2 mode or byte mode).

If already set to one of these two modes, switch to
the other setting (see Section 10.2.)

PC may not be capable of operating in the required
parallel port mode. This is true of some laptopStill no I2C communication computers. Use a different computer, preferably a
desktop PC.

When WinVCC is started and the WinVCC Configuration dialog box is closed with OK, the I2C system test
is performed (unless the I2C System Test program option is disabled).

If the I2C system test fails, a dialog box like Figure 21 appears. This example reports that a read from
TVP9900 failed, using slave address 0xB8, subaddress 0x57. The data read was 0x05. The expected
data was 0x01.

After noting which device had a problem, click OK to continue. Next, the Corrective Action Dialog box
appears to help fix the problem.
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10.2 Corrective Action Dialogs

Troubleshooting

Figure 21. I2C System Failure Dialog Box

After closing the I2C system test report dialog box, a corrective action dialog box appears (see Figure 22).

Figure 22. Corrective Action Dialog Box

1. If the parallel port cable is NOT connected between to PC and the TVP9900EVM or if the EVM power
is not on:

a. Click No.
b. The dialog box shown in Figure 23 appears instructing you to correct the problem.
c. Correct the problem.
d. Click OK to continue. The main menu dialog should appear.

Figure 23. Corrective Action Required
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10.2.1 Setting the PC Parallel Port Mode

10.2.2 General I2C Error Report

Troubleshooting

2. If the cable is connected from the PC parallel port to the TVP9900EVM and the EVM power is on:

a. Click Yes.
b. The dialog box shown in Figure 24 appears. This dialog box appears if the PC parallel port mode

setting may need to be changed.

Note: Only run the PC BIOS setup program if the I2C communication problem cannot be
resolved in another way (correct slave address settings, reset, or power cycle the
EVM and/or check that the device type selected was TVP9900).

c. Click OK to continue.
d. The main menu dialog appears.
e. Click Exit in the File menu to exit the program.
f. See troubleshooting guide in Section 10.1.

Figure 24. Corrective Action Required

Note: Only run the PC BIOS setup program if the I2C communication problem cannot be
resolved in another way (correct slave address settings, reset, or power cycle the EVM
and/or check that the device type selected was TVP9900).

1. Restart the PC.
2. During the boot process, enter the BIOS setup program by pressing the required key (usually the initial

text screen tells you which key to press).
3. Find the place where the parallel port settings are made.
4. Set the parallel port LPT1 at address 378h to ECP mode or bidirectional mode (sometimes called PS/2

mode or byte mode). If one of these two modes is already selected, then change to the opposite mode.
5. Exit and save changes.

The error report shown in Figure 25 appears when an I2C error occurs at any time other than after the I2C
system test. In this example, there was an acknowledge error at slave address 0xB8 (the receiver
module). The error occurred on Read Cycle Phase 1 on the device (slave) address byte.

Figure 25. I2C Error
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11 TVP9900EVM Schematics

TVP9900EVM Schematics

This chapter contains the TVP9900EVM schematics.
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Tuner Control Options:
WinVCC has option to select if TVP9900 is tuner I2C master
EVM Jumper Control options with JP4 and JP5:

Position 2-3:  TVP9900 controls tuner (default)
Position 1-2:  The PC controls tuner
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TUNER_SCL_5V

R32

0

R28

0

R20
10K

R5
3.3K

R6
3.3K

TUNER_SDA_5V
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Level Shifter for Tuner I2C - 3.3V to 5V
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TUNER_SCL_3.3V

D3.3V
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3.3K

D3.3V

R29
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R30

0

DNP R30 for 5V I2C signals to Tuner board (default)

DNP

DNP R29 for 3.3V I2C signals to Tuner board

1312
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GPIO[4..0]
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+5V 3.3V_SUPPLY 1.5V_SUPPLY

GPIO5_SYNC
GPIO6_LOCK
GPIO7_INTREQ

DATAOUT[6..0]

GPIO[4..0]

Use through-hole for TP's

TPs also on I2C and TVP9900 pages

TP3
DGND

TP6
1.5V

TP5
3.3V

TP4
+5V
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1
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1K

Q2

NPNANTCNTL
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ANT_DATAOUT

ANT12V

ANTCNTL

Output from TVP9900
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DGND DGND

ANT12V

5VDC

5VDC

DGND

D3.3V

5VDC

C72
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C34
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DGND
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Position 1-2: Disable Mode B (default)
Position 2-3: Enable Mode B

R9
3.3K

R10
3.3K

R21

10K
SmAn_Mode_B

ANT_DATAOUT R49 33 ANTCNTL

Smart Antenna Mode A

Pin 29, ANTCNTL I/O

1

2

H4

ANT12V

DNP

DNP

A2 B 4

GND 3VCC 5OE1

U8

SN74CBTLV1G125DCKR

2.0

Output from TVP9900 to Antenna

Output from TVP9900 to Antenna uses Mode A circuit below
Output from Antenna to TVP9900 uses Mode B circuit above

GPIO1 Output = Direction of Pin 29 (ANTCNTL)

1 = Output from TVP9900 to Antenna
0 = Input from Antenna to TVP9900

Connect 12V power supply to support Smart Antenna

C79
47uF_16V

C80
22uF_16V

1
3

2
JP6

Mode B

JP 6: Mode B Selection (EVM supports 1 pin mode only)

GPIO1
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Power_Regulator - Page 2
Power_Regulator.Sch
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TUNER_SCL_5V

AGCOUT
TUNER_IF_OUT1
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Tuner - Page 3
Tuner.Sch

4.0

TUNER_IF_OUT1
TUNER_IF_OUT2
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AGCOUT

Connector - Page 4
Connector.Sch
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TGND
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LED1
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4.0

C2
0.1uF

C5
470pF

C4
0.1uF

TGND

5VDC TU5V

TGND

Power ON LED (+5V)

L1 and C1 - C2 should be placed close to connector
L2 and C3 - C5 should be placed close to tuner

L1

2u2H +
C3

220uF 10V

L2

22uH+
C1

47uF 10V
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TGNDAGCOUT

TUNER_IF_OUT1
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Uses Thomson DTT76801 with integrated DC to DC converter

TGND

TUNER_AS

Tuner I2C Address Selection
Position 1-2:  Address = 0xC0
Position 2-3: Address = 0xC6

R5

10K

TU5V

TGND

TU5V

Open: Address = 0xC2 (default)

1
3

2
JP1
I2C_ADR

TP1
TGND

TP2
TU5V

C7
DNP 12pF

L3
DNP 680nH 
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0R

R2
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IFOUT1
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SHIELD1 M1
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IF out 17RF_AGC 5SCL14

SDA15

AS16

IF_AGC18

D-IF_OUT1 21

D-IF_OUT2 20

SHIELD2 M2
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Vt11

GND12

OOB out1

NC3

NC4

DC Feed-through6 NC13

GND 19

NC7

NC8

NC 9

NC 10

U1

THOMSON_DTT76801_TUNER
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GPIO3
GPIO4

nRESET
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HEADER 18X2
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TGND

TUNER_SDA_5VTUNER_SCL_5V

TUNER_IF_OUT1

TUNER_IF_OUT2

AGCOUT

Samtec TSW-118-08-G-D-RA

CLKIN_4_25MHz
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